[Matroska-users] RE: Problem muxing a ts stream

Ivan Kowalenko ivan.kowalenko at gmail.com
Sun Apr 27 15:25:09 CEST 2008


Matroska uses two letter language codes. Try en instead of eng.

- original message -
Subject:	Problem muxing a ts stream
From:	"Rob Poretti" <rporetti at cogeco.ca>
Date:		04/26/2008 16.08

Hi!

I have two ts streams (part 1 and part 2) of the movie "Baraka" -  that I'm trying to mux to an mkv and then merge into one .mkv file.  

I'm using gdsmux to first get it to an mkv container so that I can use mkvMerge to create a single file...

The first part seemed to work fine - I ended up with two playable mkv files.  However, when I try to merge them in mkvMerge, I ran into some problems - I get errors:

MkvMerge FAILED with a return code of 2.  There were Errors:

Error: 'ENG' is neither a valid ISO639-2 nor a valid ISO639-1 code. See 'mkvMerge --list-languages' for a list of all languages and their respective ISO639-2 codes.

If I try to change the language to something else, I still get the error.  It doesn't seem to like how gdsmux created the mkv files?

Any direction here would be appreciated...

Cheers!

Rob







More information about the Matroska-users mailing list