[Matroska-users] Re: MKV Playback in Vista Ultimate x64 and MediaCenter - Looking for a bit of help...

James G. l0ngr1fl3 at hotmail.com
Fri Nov 23 20:38:15 CET 2007


Vista x64 uses 32-bit WMP as default, and 64-bit WMC as default, so you need either 32-bit and 64-bit codecs, or you need to set 64-bit WMP as default, you can google for it.
  "Rob Poretti" <rporetti at cogeco.ca> wrote in message news:003a01c823cb$061d0ec0$12572c40$@ca...
  Hi folks,

   

  New to this list and I'm admitting upfront that I've been struggling for about a month sorting out mkv playback on Media Center. Having said that, I'm not a computer neophyte - I'm a VB/SQL programmer - but - LOL! -  that makes it all the more frustrating!  Of course I will be very appreciative about any help but I believe my background will allow me get things sorted out quickly - I just need some knowledgeable direction...

   

  Anyway, I believe I've tried 3 of 4 ways of getting this done - using posted solutions that have worked for some folks, but obviously not working for me.  First off, I can playback .mkv files in WMP11 but not MC.  MC gives me the error:

   

  Cannot Play Video

  Windows Media Center cannot open the file.

   

  I have a brand new HTPC system that I built and installed Vista Ultimate 64-bit.  I'm willing to reinstall Vista yet again (already done it twice!)  I'm comfortable using RegEdit and I've been currently using GraphEdit and Filmerit to troubleshoot problems.  I have the latest CCCP package and a number of other CODEC packages - although I've uninstalled all of them at this point.  Right now, the CCCP Community CODEC Pack 2 is the only thing installed - but I believe it has the ffdshow rev 1324 as part of it's payload.

   

  I've also run the Matroksa Diagnostic software on a MKV file...

   

  The Directshow rendering shows a few failed items - specifically:

   

  62> Failed connecting pin to DirectVobSub (auto-loading version), removing it now.

  265> Failed connecting pin to DirectVobSub (auto-loading version), removing it now.

   

  Everything else described as "OK"

   

  Filmerit shows 0 errors amongst 164 filters...

   

  GraphEdit shows an .mkv render graph as follows:

   

  Movie.mkv   - Video  à ffdshow Video Decoder input  à Video Renderer VMR Input()

  Movie.mkv   - Audio  à ffdshow Audio Decoder input  à Default Direct Sound Device Audio Input pin (rendered)

   

  That's about all the information I can think of that might help, but if anyone needs something else, I'd be happy to get what you need...

   

  Cheers!

   

  Rob

   



------------------------------------------------------------------------------


  _______________________________________________
  Matroska-users mailing list
  Matroska-users at lists.matroska.org
  http://lists.matroska.org/cgi-bin/mailman/listinfo/matroska-users
  Read Matroska-Users on GMane: http://dir.gmane.org/gmane.comp.multimedia.matroska.user
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.matroska.org/pipermail/matroska-users/attachments/20071123/f4c9e85b/attachment-0002.html>


More information about the Matroska-users mailing list