[Matroska-users] Cannot Extract Tracks (Garbled Output)

Mark Kane mark at mkproductions.org
Fri Jun 9 18:00:14 CEST 2006


On Fri, Jun 09, 2006, at 02:03:35 -0500, Ivan Kowalenko wrote:
> Sounds like MPlayer can't recognize the file, and deciding it's a
> raw DV stream (happens quite commonly with damaged AVI/MPEG headers).
> I have to ask, though: what version are you using? Some MPlayer  
> versions have had some bad demuxers. You might want to use the
> latest SVN for the best results. Anyway, sounds like a busted AVI
> header. Have you tried forcing the use of a decoder, such as
> - -vc ffmpegh264
> to force the use of the FFMPEG H.264 decoder, instead of MPlayer  
> deciding on the raw DV decoder. Just use -ac help OR -vc help to  
> determine what decoders are available.

Hi, thanks for the reply. 

MPlayer version is 0.99.7_14. I've also tried playing the extracted .avi
in VLC and Xine, neither will play it. VLC shows the seek bar going from
left to right for about 2 seconds, then stops, but no video shows (it
doesn't show an audio/video track either). Xine says it can't find a
demuxer plugin. With the "More" button, it says:

xine: found demuxer plugin: Elementary MPEG stream demux plugin

MPlayer and Xine both play the original Matroska files fine, however
VLC won't show video output on the original .mkv. It shows the seek bar
moving throughout the entire clip duration, and shows "avc1" as the
codec, plays the audio, but no video output.

I tried the mplayer suggestion of the forcing video codec, but it
doesn't play anything this time. Here is what it says:

Playing file.avi.
AVI: Missing video stream!? Contact the author, it may be a bug :(
RAWDV file format detected.
VIDEO:  [DVSD]  720x480  24bpp  29.970 fps    0.0 kbps ( 0.0 kbyte/s)

> Can you send us the output of mkvinfo? This should help us determine  
> if it's a damaged file, or a problem with your software. Also, have  
> you tried remuxing the file? IE: mkvmerge (input).mkv -o  
> (output).mkv? Perhaps that might help fix the file, if there's  
> something wrong with it.

Sure, the output of mkvinfo is attached. I tried remuxing but it's the
same result. I think the original Matroska files are fine, just
something in the process of extracting the tracks.

Thanks again!

-Mark

-- 
Internet Radio:
Party107 (Trance/Electronic) - http://www.party107.com
Rock 101.9 The Edge (Rock) - http://www.rock1019.net

IRC:
MIXXnet IRC Network - irc.mixxnet.net (Nick: MIXX941)

GnuPG Public Key:
http://www.mkproductions.org/mk_pubkey.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mkvinfo_mixx941_1
Type: application/octet-stream
Size: 1582 bytes
Desc: not available
URL: <http://lists.matroska.org/pipermail/matroska-users/attachments/20060609/8e0782db/attachment-0002.obj>


More information about the Matroska-users mailing list