[Matroska-users] Cannot Extract Tracks (Garbled Output)

Ivan Kowalenko ivan.kowalenko at gmail.com
Fri Jun 9 09:03:35 CEST 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Jun 8, 2006, at 16.58, Mark Kane wrote:

> Hi everyone. I'm new to Matroska, but it looks like a very interesting
> project!
>
> I have a few clips here that I cannot seem to extract using
> mkvextract. Doing a `mkvmerge -i` on the file shows the following
> info:
>
> Track ID 1: video (V_MPEG4/ISO/AVC)
> Track ID 2: audio (A_AC3)
>
> However, when I try to extract it, the output is all garbled blocks of
> colors and mplayer gives these errors:
>
> AC EOB marker is absent pos=66
> AC EOB marker is absent pos=66
> AC EOB marker is absent pos=92
> [etc]

Sounds like MPlayer can't recognize the file, and deciding it's a raw  
DV stream (happens quite commonly with damaged AVI/MPEG headers). I  
have to ask, though: what version are you using? Some MPlayer  
versions have had some bad demuxers. You might want to use the latest  
SVN for the best results. Anyway, sounds like a busted AVI header.  
Have you tried forcing the use of a decoder, such as
- -vc ffmpegh264
to force the use of the FFMPEG H.264 decoder, instead of MPlayer  
deciding on the raw DV decoder. Just use -ac help OR -vc help to  
determine what decoders are available.

>
> I tried a few variations, but the command I've tried for both clips so
> far is this. It goes fine without any errors, but the output of both
> the avi and ac3 is all garbled.
>
> mkvextract tracks file.mkv 1:test.avi 2:test.ac3
>
> Sorry if this is a common question, but I did search the FAQ and lists
> but didn't come up with anything.

Can you send us the output of mkvinfo? This should help us determine  
if it's a damaged file, or a problem with your software. Also, have  
you tried remuxing the file? IE: mkvmerge (input).mkv -o  
(output).mkv? Perhaps that might help fix the file, if there's  
something wrong with it.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (Darwin)

iD8DBQFEiR1J187keuSyQSQRAlEIAKCJaOtCra86FSxsnRkJmz1xChRRygCdErS5
0GFNv97qtysQk6rkGxFLino=
=1IlW
-----END PGP SIGNATURE-----



More information about the Matroska-users mailing list