[Matroska-users] Error opening MKV file

Ivan Kowalenko ivan.kowalenko at gmail.com
Tue Aug 8 02:44:34 CEST 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Aug 7, 2006, at 03.08, Marcelo Durand ((mdurand)) wrote:

> Guys,
>
> I tried to open an MKV (diag info below) with no luck. I guess I  
> have all the right SW installed.
> Can somebody give me an idea as to why it would not open?
> A datapoint: I tried all media players I have (windows mediaplayer,  
> zoomplayer, etc) and nothingworks
>         however, when I try with winamp, I hear the sound in the  
> file but do not see the video.
>
> Any help appreciated.
>
> Regards
>
>
> Matroska file info : C:\My Music\Downloaded\Lossless\The.Avengers. 
> 1965.S04E01.The.Town.of.No.Return.DVDRip.XviD-PP.mkv
> File size : 345.21 MB
> TEbmlReader.ReaderHeader : EBML header ID not found (found 0xF1)
This probably means a damaged EBML header. Might be bad, might not be  
fatal. Probably not that critical of a thing.

[snip]
> RenderFile with DirectShow : Cannot play back the file. The format  
> is not supported. (0x80040265)
Well, there's your problem (likely). It's probable that you don't  
have an XviD codec installed.
> DirectShow detailed rendering :
> 0> MyRenderFile : C:\My Music\Downloaded\Lossless\The.Avengers. 
> 1965.S04E01.The.Town.of.No.Return.DVDRip.XviD-PP.mkv
> 0> Creation of GraphBuilder : OK
> 0> Creation of FilterMapper2 : OK
> 32> Adding graph to ROT : OK
> 47> Creation of source filter : OK
> 47> # Rendering output pin C:\My Music\Downloaded\Lossless 
> \The.Avengers.1965.S04E01.The.Town.of.No.Return.DVDRip.XviD-PP.mkv 
> (Output)
>
> 47> Filters matching mediatype : Ligos MPEG Audio Decoder,  
> DirectVobSub (auto-loading version), DivXAntiFreeze, Ligos MPEG  
> Splitter, ASX v.2 file Parser, .RAM file Parser, Matroska Splitter,  
> AVI Splitter, AC3 Parser Filter, Subtitle Parser, ASX file Parser,  
> NSC file Parser, OpenMG Audio Decrypt Splitter, MPEG-2  
> Demultiplexer, QuickTime Movie Parser, WavPack Audio Splitter, Ogg  
> Splitter, Nero Video Decoder, Nero DVD Decoder, MPEG-1 Stream  
> Splitter, Nero Splitter
Yep, I don't see an XviD codec in there. Try installing one, and see  
what it does.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (Darwin)

iD8DBQFE195yh/R/wkI6oPQRAt4bAJwJfj+Vs0KldQAd7xdMXkdJx2AnMACgsQcz
3Dnyzyb9X71wZp1XdYeLi/s=
=0+mP
-----END PGP SIGNATURE-----



More information about the Matroska-users mailing list