[Matroska-users] mkvmerge segmentation fault

Moritz Bunkus moritz at bunkus.org
Thu Dec 15 09:53:51 CET 2005


Hey,

On Wednesday 14 December 2005 16:38, Sami Kiiskila wrote:

> What might be the reason for mkvmerge generating segmentation fault every
> time I try to use it?

Bad compiler, library conflicts etc etc.

> First I compiled "libebml-0.7.6", "libmatroska-0.8.0",

How did you compile them? My advice is to compile only the static
versions by calling "make staticlib" and "make install_headers
install_staticlib". I've had problems with shared libs on the past.

> Always same thing "segmentation fault".

Not good :)

> Then I tried to install it from the RPM binary package
> "mkvtoolnix-1.6.5-1.i386.rpm", it needed flac lib and some tweaks to run
> but finally it did the same thing, shows the help page without parameters
> and segmentation fault with any input.

Not good either :(

> Now I tried to compile again with --enable-debug, still help page comes out
> fine but any input gives this time "Illegal instruction".

!??

Ok here are a couple of questions.

Which OS and which version are you using?

Which gcc version are you using (gcc -dumpversion)?

> I included the output of gdb with bt here:
> Strange that it complains of not finding any debug symbols even if I
> compiled it with --enable-debug.

Are you sure that gdb used your newly built mkvmerge and not another
version that was not compiled with debugging options? Because
--enable-debug is definitely the only switch required for getting debug
information into the executable.

> (gdb) run -i mewmew-vorbis-ssa.mkv
> Starting program: /usr/local/bin/mkvmerge -i mewmew-vorbis-ssa.mkv

Looks like a self-compiled version alright.

> #6  0x0805eaf9 in std::basic_string<char,
> std::char_traits<char>, std::allocator<char> > std::operator+<char,
> std::char_traits<char>, std::allocator<char> >(std::basic_string<char,
> std::char_traits<char>, std::allocator<char> > const&,
> std::basic_string<char, std::char_traits<char>, std::allocator<char> >
> const&) () #7  0x00757750 in __libc_start_main () from /lib/tls/libc.so.6
> #8  0x0804c081 in ?? ()
> (gdb)

Uhm.... That's not even in my code... That's inside libc's startup code?
Very strange.

> open("mewmew-vorbis-ssa.mkv", O_RDONLY|O_LARGEFILE) = 3
> --- SIGILL (Illegal instruction) @ 0 (0) ---

Hmm, so mkvmerge does at least open the file and is not breaking right
at the start (ok, you said that mkvmerge displays the help page if you
don't give it any parameters, so it is working at least "a bit").

Mosu

-- 
If Darl McBride was in charge, he'd probably make marriage
unconstitutional too, since clearly it de-emphasizes the commercial
nature of normal human interaction, and probably is a major impediment
to the commercial growth of prostitution. - Linus Torvalds

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.matroska.org/pipermail/matroska-users/attachments/20051215/64d0844c/attachment-0002.pgp>


More information about the Matroska-users mailing list