[Matroska-users] can't compile libmatroska

Moritz Bunkus moritz at bunkus.org
Sat Dec 20 13:16:41 CET 2003


Hi,

> /home/wichy/libmatroska/src/KaxBlock.cpp:490:
> `SCOPE_ALL_DATA' undeclared
>    (first use this function)

This hints at your libebml installation being too old. Please download
the latest libebml, compile and install it and make absolutely sure that
you haven't got another libebml installation sitting around somewhere
that might be used instead.

Note: If you just call 'make' in /home/wichy/libmatroska/make/linux then
EBML headers will also be looked for in /home/wichy/libebml. But also
check /usr/include/ebml and /usr/local/include/ebml, just to be sure.

Mosu

-- 
If Darl McBride was in charge, he'd probably make marriage
unconstitutional too, since clearly it de-emphasizes the commercial
nature of normal human interaction, and probably is a major impediment
to the commercial growth of prostitution. - Linus Torvalds



More information about the Matroska-users mailing list