[Matroska-users] can't compile libmatroska

Wichy Dash wichy_dash at yahoo.com
Sat Dec 20 05:33:03 CET 2003


My problem is that I cannot compile libmatroska-0.6.1,
I'm using Gentoo, I normally use the portage version,
but I've also tried the CVS version, and I get the
same error:

/home/wichy/libmatroska/src/KaxBlock.cpp:484: syntax
error before `)' token
/home/wichy/libmatroska/src/KaxBlock.cpp: In member
function `uint64
   libmatroska::KaxBlock::ReadData(...)':
/home/wichy/libmatroska/src/KaxBlock.cpp:488: `input'
undeclared (first use
   this function)
/home/wichy/libmatroska/src/KaxBlock.cpp:490:
`ReadFully' undeclared (first use
   this function)
/home/wichy/libmatroska/src/KaxBlock.cpp:490:
`SCOPE_ALL_DATA' undeclared
   (first use this function)
/home/wichy/libmatroska/src/KaxBlock.cpp:556:
`ReadCodedSizeValue' undeclared
   (first use this function)
/home/wichy/libmatroska/src/KaxBlock.cpp:564:
`ReadCodedSizeSignedValue'
   undeclared (first use this function)
/home/wichy/libmatroska/src/KaxBlock.cpp:591:
`SCOPE_PARTIAL_DATA' undeclared
   (first use this function)
make: ***
[/home/wichy/libmatroska/make/linux/../../src/KaxBlock.o]
Error 1



I can compile & install libmatroska0.5.2 without
problems, and I don't have any problems with any
problems with libebml (I can compile & install
libebml-0.6.2 also), but because some videos I have
need the lastest version of matroska, I wanted to
install it.

Thanks.

__________________________________
Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing.
http://photos.yahoo.com/



More information about the Matroska-users mailing list