[Matroska-devel] EBML spec component for review - Abstract

Sebastian G. <bastik> bastik.public.mailinglist at gmx.de
Fri May 1 13:02:17 CEST 2015


01.05.2015, 11:55 Moritz Bunkus:
> Hey,
> 
> Anyway, I don't really like the spec abstract, but I almost like your
> proposal:
> 
>> “EBML is designed to be a compact and simple binary storage format,
>> inspired by XML, for the purpose of storing and manipulating all sorts
>> of digital content and metadata in a hierarchical form with variable
>> field length."
> 
> I almost like this. However, the _purpose_ is »storing and manipulating
> all sorts of digital content and metadata«, maybe even »being compact
> and simple to parse« at the same time. The rest, »in a hierarchical form
> with variable field length«, is not its purpose, it's a technique used
> for achieving our purpose.
> 
> Maybe something more like (please, native speakers, improve the
> wording):
> 
> “EBML is designed to be a binary storage format, inspired by XML, for
> the purpose of storing and manipulating all sorts of digital content and
> metadata in a compact and simple form. It uses a hierarchical form with
> variable field length."
> 

Hello all,

I am not a native speaker, but I suggest something that reduces it to
one sentence:

"EBML is designed to be a binary format, inspired by XML, for the
purpose of storing and the possibility to manipulate all sorts of
digital content and metadata in a compact and simple form by using a
hierarchical form with variable field length."

It removes "storage" which would appear twice, but I would not mind if
it would reappear as it might be worthy to highlight that it is a
storage format.

I suggest the wording "...possibility to manipulate..." since the main
function would be its storage capabilities while the ability to have its
metadata being manipulated is 'just' a possibility, a feature, not
something that is required to be used.

While writing I realized that "manipulate" seems to have a negative
meaning to some if not most of the people. Maybe it could be replaced
with "modified".

Best regards,
Sebastian


More information about the Matroska-devel mailing list