[Matroska-devel] Opus in Matroksa Cont.

Moritz Bunkus moritz at bunkus.org
Fri May 24 22:53:10 CEST 2013


Hey,

> Maybe muxers should only allow a non 1.0f TrackTimecodeScale when a newer Matroska version (4) is forced ?
> And for the EBMLReadVersion to 4 as well.

one more thing. Introducing changes that require bumping EBML
ReadVersion up to 4 (or even higher) are pretty much guaranteed to
make any and all files unreadable by all of today's players (unless
they completely ignore that field which, in turn, would also be a
pretty bad violation and a source for serious playback issues).

So are we back to backwards-incompatible changes? Then let's do it
right and throw out the timecode-based "raw timecodes" and be done
with it...

Kind regards,
mosu


More information about the Matroska-devel mailing list