[Matroska-devel] Proposal for a better definition for the 'keyframe' flag

Jan Ekstrom jeebjp at gmail.com
Sat Jun 15 17:58:45 CEST 2013


On Sat, Jun 15, 2013 at 6:49 PM, Steve Lhomme <slhomme at matroska.org> wrote:
> A lot of rewording in the specs is needed like "timecode" to "timestamp".
>
> In this particular matter, lace has more meaning and is clearer in the
> context of a SimpleBlock

I am fine with both words, which would make the current version of the
text something like this? I'm going to poke some other people to see
if this doesn't look too bad in any way I haven't noticed myself yet.

Keyframe:

This SimpleBlock consists of laces that form a random access point.
When decoding starts from a random access point, it can be correctly
decoded, as well as all the following multiplexed data in presentation
order, without having access to previous multiplexed data in coding
order.

If a decoder needs additional data to properly initialize (such as the
parameter sets in AVC or HEVC), that data must be provided as defined
in the applicable format's mapping specification. If that additional
data is not available, this flag shall not be enabled.


Jan Ekström


More information about the Matroska-devel mailing list