[Matroska-devel] Proposal for a better definition for the 'keyframe' flag
jeebjp at gmail.com
Sat Jun 15 17:12:44 CEST 2013
On Sat, Jun 15, 2013 at 5:54 PM, Steve Lhomme <slhomme at matroska.org> wrote:
> "frames" could be replaced with "laces" since that's what it contains,
> regardless of the format (video, audio, subtitles, etc)
Looking at the Matroska page, doesn't "frame" mean "a sample of data"
( "small blocks of data (refered to as frames in matroska)" ) ? That
would make the usage of the word "frame" completely OK in this context
if the data of laces was meant.
But yes, the word "frame" is being used with multiple meanings on the
page, so in one way or another I recommend cleaning this up, and
having the word only mean one thing on the page. That said, the
definitions that use the (video) frame word aren't exactly
problemless, either. But first I would like to have the "keyframe"
(random access point) definition done.
More information about the Matroska-devel