[Matroska-devel] [proposal] new Matroska element CueDuration

Moritz Bunkus moritz at bunkus.org
Mon Sep 24 12:08:35 CEST 2012


Hey,

I just noticed that I've put CueDuration into the wrong level. At the
moment it looks like this:

CuePoint
+ CueTime (single)
+ CueDuration (single)
+ CueTrackPositions (multiple)
+-- CueTrack (single)
...

This design would mean that the duration would have to be valid for
all track numbers that the cue point refers to. This is completely
unrealistic. Therefore I suggest we simply move it one level down,
even though "TrackPositions" would not be the best name -- but we
cannot change that anymore. So the new layout would be:

CuePoint
+ CueTime (single)
+ CueTrackPositions (multiple)
+-- CueTrack (single)
+-- CueDuration (single)
...

Objections?

PS: The other new element I've added, CueRelativePosition, is already
a child of CueTrackPositions.

Kind regards,
mosu


More information about the Matroska-devel mailing list