[Matroska-devel] [proposal] add new element DefaultDeocdedFieldDuration
madshi at gmail.com
Sat Dec 29 21:52:38 CET 2012
2012/12/29 Moritz Bunkus <moritz at bunkus.org>
> following up on our discussion I'd like to propose we
> add the following new element:
Definition, short description and examples look good to me. Not sure about
the "long" description:
> For video sequences signaled as progressive it is twice
> the value of DefaultDecodedFieldDuration.
What is "it" in this sentence? I don't really understand what this sentence
means exactly. Do we need to have different definitions for interlaced and
progressive content? Doesn't the short description "The period in
nanoseconds (not scaled by TimcodeScale) between two successive fields at
the output of the decoding process" satisfy both interlaced and progressive
content? IMHO the description could end right after that one short
description, with only the examples to follow. If you want to have a
separate description for interlaced and progressive content then for
progressive content I would suggest something like: "For video sequences
signaled as progressive, DefaultDecodedFieldDuration is half of the period
between two successive frames at the output of the decoding process".
Best regards, Mathias.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Matroska-devel