[Matroska-devel] No audio using Haali splitter for TS files with MPEG4-AVC (h264) + AAC data

Florent Viguier florent.viguier at wanadoo.fr
Thu Jul 24 20:54:53 CEST 2008


Nevermind I found a convenient way to read these files...
And I also found out that I should have posted this on
doom9.org's forums instead. Sorry for bothering the
Matroska developers ! :p

My method is the following :
1- Demux the audio part of the stream using DGAVCDec,
keeping the default name for the aac file that is
generated.

2- Open the TS file with MPC. The AAC file is magically
detected by MPC that will read the audio file in sync
with the video automatically ! (seeking works too !)


Gabest is the best !

It would still be great if Haali's splitter could
extract the audio too, so I could use one single
DirectShowSource() in AviSynth to use any AviSynth
compatible program to re-encode the stream.

And I still found no way to directly read the live TV
streamed over RTSP using MPC and not VLC.

/Florent/


Florent Viguier a écrit :
> Hello.
> 
> I'm writing this post because I have trouble reading
> TS files recorded from the digital televion service
> provided by my ISP (Free : http://www.free.fr/).
> I had no problem before because they used standard
> MPEG2 (I think it was PS files, at least that's what
> I can see in VLC's messages when I open them with it)
> that Media Player Classic can parse by itself.
> 
> But now they have switched to another format that I can correctly
> open with VLC (video + sound), but with any DirectShow-based
> program I have video but no audio. In VLC's messages, it says that
> it uses the 'ts' module to open the file, that the video codec is
> h264, and that the audio is AAC. I'd like to use Media Player
> Classic instead of VLC since it can make use of CoreAVC instead
> of the slow h264 decoder bundled with VLC (ffmpeg ?). Currently the
> video does play using CoreAVC, but as I said, no audio...
> 
> When I try to render one of these TS files in GraphEdit, I can
> see that Haali splitter is being used, but it has only a video
> out pin, but no audio pin. So I guess it cannot read the audio
> part of the file. Since these files come from "live" recording
> this may have something to do with the lack of header or
> something... (I dont know how these TS files work)
> 
> By the way, if I use Media Player Classic's internal
> "MPEG PS/TS/PVA" splitter, the exact same problem happens.
> I also tried changing the file extension to mpg and mp4 but
> with no luck.
> 
> You can find a short sample file here :
> http://thetreehouse.free.fr/images_stockees/ts_file_sample.ts
> (328 kilobytes only : SD version, so this one works perfectly
> in VLC, but my ISP also provides an HD version that I can't read
> smoothly with VLC)
> 
> The file itself was recorded using a program called
> adslTV which I think makes use of VLC to receive the
> video stream (RTSP protocol) and save it to a file.
> 
> I hope this post isn't irrelevant or in the wrong place.
> Tell me if there is a known workaround to this problem.
> You can ask me for other sample files if you want.
> 
> PS: If someone here knows a DirectShow filter to open RTSP streams,
> tell me. I tried Morgan RTP DShow filter, but when I start it,
> it just continuously fills up the memory and nothing plays...
> And I have to use the task manager to shut down MPC.
> 
> Thanks in advance.
> 
> \Florent\
> 
> _______________________________________________
> Matroska-devel mailing list
> Matroska-devel at lists.matroska.org
> http://lists.matroska.org/cgi-bin/mailman/listinfo/matroska-devel
> Read Matroska-Devel on GMane: http://dir.gmane.org/gmane.comp.multimedia.matroska.devel
> 




More information about the Matroska-devel mailing list