[Matroska-devel] Thumbnails offset not working

JS nevermore4ever at gmx.net
Fri Nov 9 01:38:41 CET 2007


Hello,


I hope this is the right list to send bug reports to, and I'd be glad to get an answer, however I don't want to subscribe to any mailing lists (not beeing a developer and stuff).

Anyway, I use the latest Haali Media Splitter, my OS is Windows Vista Ultimate 64bit. After a few modifications to the registry I get thumbnails for mkv-files in 32bit Explorer windows (I mainly use the 32bit version now). However, the thumbnails offset setting has no effect. The option to switch thumbnails extraction on or off doesn't, either. I tested several values from 0 over 10, 100, 1000, 10000 to 100000 to make sure that it really is milliseconds, not seconds, and of course cleared the thumbnail cache between tests.

Since the first frame is often black, I got mostly black thumbnails, wondering if it might be a problem with the codec/filter (then again it should show an icon, not a thumbnail, shouldn't it?). However I finally got an mkv-file which has a non-black first frame, some letters are recognizable - I always get this same first frame to show, no matter which thumbnails offset I use (I get them even with thumbnails extraction set to "no"). If I uninstall the splitter, I get no thumbnails, so I doubt another application creates them instead.


But the settings are not lost; 5000 stays to be 5000 and so on, it just doesn't work. I once tried to run the Media Splitter Settings as an administrator, though, with the result that splitter.ax cannot be found. As a restricted user the settings can be edited without a problem. Funny, isn't it?



If the offset setting worked, this would be THE solution for creating thumbnails for me (at least for videos - I can't find a good one for pictures :-( ).


Sincerely,
JS
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.matroska.org/pipermail/matroska-devel/attachments/20071109/43088084/attachment.html>


More information about the Matroska-devel mailing list