[Matroska-devel] Matroska pack

Moritz Bunkus moritz at bunkus.org
Sun Jan 2 01:20:25 CET 2005


Hey,

After reading again that thread on the corecodec forum about Matroska
playback problems on Windows 98 I decided to recreate it. I installed
Win98 in VMWare, downloaded the full pack 1.0.3, chose the standard
installation options, installed DirectX 8.1, installed TCMP
4.0.something, and tried to play a file. Didn't work.

Next step: MatroskaDiag.exe. It told me that neither splitter was
installed. Therefore I tried "regsvr32 MatroskaSplitter.ax" which failed
with a message like "result was 0x0000001f". Ok, next step: downloaded
Gabest's Matroska splitter from sourceforget and tried "regsvr32
MatroskaSplitter.ax" from the non-Unicode directory. Lo and behold, that
worked.

Now TCMP still complains about not being able to find an audio device,
but that's secondary. The point is that our beloved Matroska pack is
broken on non-Unicode Windows versions.

Mosu

-- 
If Darl McBride was in charge, he'd probably make marriage
unconstitutional too, since clearly it de-emphasizes the commercial
nature of normal human interaction, and probably is a major impediment
to the commercial growth of prostitution. - Linus Torvalds



More information about the Matroska-devel mailing list