[Matroska-devel] Questions / suggestions regarding tags for "CD-in-Matroska"

Steve Lhomme steve.lhomme at free.fr
Sun Sep 26 11:00:07 CEST 2004


Steve Lhomme a écrit :

>> CD-back: IMAGE_COVER_BACK (also good for movies)
>>
>> CD-booklet: This might be several pages or none. As such, it might be 
>> better suited for a chapter definition, for instance SCANNED_PAGES, 
>> with tags such as PAGE_1, PAGE_2, etc.
> 
> 
> Yes, these all look like valid possibilities. IMO we should all merge 
> them into 1 tag that could be SLEEVE_TYPE. That would be a number like :
> 
> * -1 front cover
> * -2 back cover
> * -3 inside CD (on transparent CDs)
> *  0 page 0 of the booklet (if different than the front cover)
> *  1 page 1 of the booklet
> *  . etc

We also have to think about CD sets that can have a booklet per CD. In 
this case, we have to target the corresponding files in the part that 
describes the CD... And this is currently *impossible* with the system 
we have. Because that would mean using a few attachment UIDs in the same 
target as a Chapter UID. And in that case we have never specified if it 
means a OR or AND between the targetted elements. When using multiple 
chapter targets, it means a OR. But then if we add attachment to the 
pack, it means an AND.

Maybe we could target only the attachments (with a OR, like for 
chapters) and also use a TargetTypeValue of 40 (PART/SESSION) for these 
attachments... But then we don't know to what "chapter" part it relates 
to...

We could assume that it's always a OR between UIDs of the same type 
(chapter, attachment) and an AND between UIDs of different types. If you 
need a OR, you just don't use them in the same target 'pack'.

Everyone agrees ? (if so I'll add a remark on that in the specs)



More information about the Matroska-devel mailing list