[Matroska-devel] Matroska Pack 1.0.2 Doesn't Support XviD 1.0.1 Properly

Christian HJ Wiesner chris at matroska.org
Sat Jul 17 08:43:33 CEST 2004


Liisachan wrote:

>Hi,
>Im wondering if this is a known problem for Matroska team:
>[Abstract]
>Matroska Pack (full) 1.0.2 comes with ffdshow 2003-05-23
>by default, which, however, plays XviD 1.0.1 in an improper way, 
>making ppl misunderstand that MKV is an awkward, non-smooth 
>format.
>
Liisachan,

in fact this is one of the most annoying problems in the current 
matroska packs, and we are well aware of this.

The big problem is, all newer versions of ffdshow are coming ( which i 
find VERY annoying to be honest ) with FFvfw bundled, and for licensing 
reasons we definitely decided againt distributing a working MPEG4 
encoder in our packs. Some of our team are family men or have a job, we 
cant risk to have the MPEG-LA standing outside our houses and trying to 
sue us for millions of US$'s of lost revenues, because matroska pack is 
distributed several 10.000 times per months ( check 
http://packs.matroska.org to get numbers ).

What we need is a newer ffdshow build, but WITHOUT FFvfw bundled !!! 
Frankly speaking, i dont like the way ffdshow has been taking lately, no 
offense to Milan. Sure, FFMPEG is a very powerful library, but IMO its 
wrong to try to make an 'all-in-one' DirectShow filter based on it, as 
this is completely against the idea of DirectShow.

Anyhow, we are well aware that the next packs have to come with such an 
updated decoder, one way or another, as now there are more and more XviD 
1.x copies floating around. Thanks again for pointing us to that, we 
really have to adress this soon.

Best regards

Christian





More information about the Matroska-devel mailing list