[Matroska-devel] MatroskaSplitter Sound-skip Bug Fixed in theone with TTADS?

Christophe PARIS christophe.paris at free.fr
Fri Jul 9 13:45:12 CEST 2004


Liisachan wrote:
>>>What *is* surprising is, this problem is also fixed if I use the old
>>>version 1.0.2.0 of the splitter. Yes, 1.0.2.0 splits TTA in MKV
>>>decently.
> 
> 
> 1.0.2.0 doesnt have this problem, but it cannot handle
> track names (in sub tracks, for example) properly.

Yes, as I have said, 1.0.2.0 doesn't use the same codebase.


> So atm, there is no Matroska Splitter
> that works perfectly, as Martin from the RadLight team says:
> "The only problem is the extremely buggy MKV splitter :Z It's 
> really pain to make a support for something that does not work 
> 100%"........

Current official 1.0.2.3 works not to bad if you forgot about the 
stuttering problem.

Perfection doesn't exist ;-)
Btw any idea of fix, more information about the problem, are always welcome.


> I thought 1.0.2.3 coming with TTADS* mightve been OK,
> but it still has the same problem. It reports the video 
> framerate 25.0 even tho it is actually 23.97 or something,
> which seems to be related to the skippy sound problem.

Hmm, I'm not sure this framerate is used anywhere, and I donno at the 
moment where it's read from.
So you still have skippy sound problem with 1.0.2.3 TTA edition ?


> Im guessing it would be great if someone could release a 
> workaround version while waiting Gabest fixes it perfectly,
> because we are going to need modified splitter anyway for TTA 
> (and WV)

Yes, we should probably add wavpack support in the splitter/demuxer and 
then release a new official version, even if other wavpack filters are 
not done yet.


> * Another question:
> This modified pre-release splitter is only for Win2K/XP?
> (Unicode version?)

Yes it's a unicode version.

Regards,
Toff



More information about the Matroska-devel mailing list